Reactor Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of modules: 11
Number of dependencies (NOD): 88
Number of unique artifacts (NOA): 96
Number of version-conflicting artifacts (NOC): 5
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 91 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in modules

org.apache.maven:maven-artifact

[Error]
3.0
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.2:provided
       \- org.apache.maven:maven-artifact:jar:3.0:provided

3.0.5
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    +- org.apache.maven:maven-plugin-api:jar:3.0.5:provided
    |  \- (org.apache.maven:maven-artifact:jar:3.0.5:provided - omitted for conflict with 3.0)
    \- org.apache.maven:maven-core:jar:3.0.5:provided
       \- (org.apache.maven:maven-artifact:jar:3.0.5:provided - omitted for conflict with 3.0)

org.codehaus.plexus:plexus-utils

[Error]
1.5.5
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.apache.maven:maven-core:jar:3.0.5:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:provided - omitted for conflict with 2.0.6)

2.0.4
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.2:provided
       \- org.apache.maven:maven-artifact:jar:3.0:provided
          \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:provided - omitted for conflict with 2.0.6)

2.0.6
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    +- org.apache.maven:maven-plugin-api:jar:3.0.5:provided
    |  \- org.apache.maven:maven-model:jar:3.0.5:provided
    |     \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
    \- org.apache.maven:maven-core:jar:3.0.5:provided
       +- org.apache.maven:maven-settings:jar:3.0.5:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
       +- org.apache.maven:maven-settings-builder:jar:3.0.5:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
       +- org.apache.maven:maven-repository-metadata:jar:3.0.5:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
       +- org.apache.maven:maven-model-builder:jar:3.0.5:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
       +- org.apache.maven:maven-aether-provider:jar:3.0.5:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:2.0.6:provided - omitted for conflict with 2.0.4)
       \- org.codehaus.plexus:plexus-utils:jar:2.0.6:provided

2.1
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.apache.maven:maven-plugin-api:jar:3.0.5:provided
       \- org.sonatype.sisu:sisu-inject-plexus:jar:2.3.0:provided
          \- (org.codehaus.plexus:plexus-utils:jar:2.1:provided - omitted for conflict with 2.0.4)

org.hamcrest:hamcrest-core

[Error]
1.1
  1. com.btmatthews.maven.plugins.ldap:format-api:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  2. com.btmatthews.maven.plugins.ldap:format-dsml:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  3. com.btmatthews.maven.plugins.ldap:format-ldif:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  4. com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  5. com.btmatthews.maven.plugins.ldap:server-api-test:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:compile
       \- (org.hamcrest:hamcrest-core:jar:1.1:runtime - omitted for conflict with 1.3)

  6. com.btmatthews.maven.plugins.ldap:server-opendj:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  7. com.btmatthews.maven.plugins.ldap:server-unboundid:jar:1.3.2
    \- org.mockito:mockito-core:jar:1.10.19:test
       \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

  8. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.powermock:powermock-api-mockito:jar:1.6.5:test
       \- org.mockito:mockito-core:jar:1.10.19:test
          \- (org.hamcrest:hamcrest-core:jar:1.1:test - omitted for conflict with 1.3)

1.3
  1. com.btmatthews.maven.plugins.ldap:format-api:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  2. com.btmatthews.maven.plugins.ldap:format-dsml:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  3. com.btmatthews.maven.plugins.ldap:format-ldif:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  4. com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  5. com.btmatthews.maven.plugins.ldap:server-api-test:jar:1.3.2
    \- junit:junit:jar:4.12:compile
       \- org.hamcrest:hamcrest-core:jar:1.3:compile

  6. com.btmatthews.maven.plugins.ldap:server-opendj:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  7. com.btmatthews.maven.plugins.ldap:server-unboundid:jar:1.3.2
    \- junit:junit:jar:4.12:test
       \- org.hamcrest:hamcrest-core:jar:1.3:test

  8. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    +- org.powermock:powermock-api-mockito:jar:1.6.5:test
    |  +- org.hamcrest:hamcrest-core:jar:1.3:test
    |  \- org.powermock:powermock-api-mockito-common:jar:1.6.5:test
    |     \- (org.hamcrest:hamcrest-core:jar:1.3:test - omitted for duplicate)
    \- com.btmatthews.maven.plugins.ldap:server-api-test:jar:1.3.2:test
       \- junit:junit:jar:4.12:test
          \- (org.hamcrest:hamcrest-core:jar:1.3:test - omitted for duplicate)

org.objenesis:objenesis

[Error]
2.1
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.powermock:powermock-api-mockito:jar:1.6.5:test
       \- org.mockito:mockito-core:jar:1.10.19:test
          \- org.objenesis:objenesis:jar:2.1:test

2.2
  1. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- org.powermock:powermock-api-mockito:jar:1.6.5:test
       \- org.powermock:powermock-api-mockito-common:jar:1.6.5:test
          \- org.powermock:powermock-api-support:jar:1.6.5:test
             \- org.powermock:powermock-reflect:jar:1.6.5:test
                \- (org.objenesis:objenesis:jar:2.2:test - omitted for conflict with 2.1)

org.slf4j:slf4j-api

[Error]
1.5.2
  1. com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2
    \- org.apache.directory.server:apacheds-protocol-shared:jar:1.5.5:compile
       \- org.apache.mina:mina-core:jar:2.0.0-M6:compile
          \- (org.slf4j:slf4j-api:jar:1.5.2:compile - omitted for conflict with 1.7.21)

  2. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2:test
       \- org.apache.directory.server:apacheds-protocol-shared:jar:1.5.5:test
          \- org.apache.mina:mina-core:jar:2.0.0-M6:test
             \- (org.slf4j:slf4j-api:jar:1.5.2:test - omitted for conflict with 1.7.21)

1.5.6
  1. com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2
    +- org.apache.directory.server:apacheds-core:jar:1.5.5:compile
    |  +- org.apache.directory.server:apacheds-xdbm-search:jar:1.5.5:compile
    |  |  +- org.apache.directory.server:apacheds-schema-extras:jar:1.5.5:compile
    |  |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-xdbm-tools:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-schema-bootstrap:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-schema-registries:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-core-shared:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-core-constants:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-utils:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-jdbm-store:jar:1.5.5:compile
    |  |  +- org.apache.directory.server:apacheds-core-avl:jar:1.5.5:compile
    |  |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-xdbm-base:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-bootstrap-extract:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.shared:shared-cursor:jar:0.9.15:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    +- org.apache.directory.server:apacheds-core-entry:jar:1.5.5:compile
    |  +- org.apache.directory.server:apacheds-jdbm:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    +- org.apache.directory.server:apacheds-protocol-ldap:jar:1.5.5:compile
    |  +- org.apache.directory.shared:shared-asn1-codec:jar:0.9.15:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-kerberos-shared:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  +- org.apache.directory.server:apacheds-bootstrap-partition:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    +- org.apache.directory.server:apacheds-protocol-shared:jar:1.5.5:compile
    |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    +- org.apache.directory.server:apacheds-server-jndi:jar:1.5.5:compile
    |  +- org.apache.directory.server:apacheds-core-jndi:jar:1.5.5:compile
    |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
    \- org.apache.directory.shared:shared-ldap:jar:0.9.15:compile
       +- org.apache.directory.shared:shared-asn1:jar:0.9.15:compile
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
       +- org.apache.directory.shared:shared-ldap-constants:jar:0.9.15:compile
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)
       \- (org.slf4j:slf4j-api:jar:1.5.6:compile - omitted for conflict with 1.7.21)

  2. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    \- com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2:test
       +- org.apache.directory.server:apacheds-core:jar:1.5.5:test
       |  +- org.apache.directory.server:apacheds-xdbm-search:jar:1.5.5:test
       |  |  +- org.apache.directory.server:apacheds-schema-extras:jar:1.5.5:test
       |  |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-xdbm-tools:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-schema-bootstrap:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-schema-registries:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-core-shared:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-core-constants:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-utils:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-jdbm-store:jar:1.5.5:test
       |  |  +- org.apache.directory.server:apacheds-core-avl:jar:1.5.5:test
       |  |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-xdbm-base:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-bootstrap-extract:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.shared:shared-cursor:jar:0.9.15:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       +- org.apache.directory.server:apacheds-core-entry:jar:1.5.5:test
       |  +- org.apache.directory.server:apacheds-jdbm:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       +- org.apache.directory.server:apacheds-protocol-ldap:jar:1.5.5:test
       |  +- org.apache.directory.shared:shared-asn1-codec:jar:0.9.15:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-kerberos-shared:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  +- org.apache.directory.server:apacheds-bootstrap-partition:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       +- org.apache.directory.server:apacheds-protocol-shared:jar:1.5.5:test
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       +- org.apache.directory.server:apacheds-server-jndi:jar:1.5.5:test
       |  +- org.apache.directory.server:apacheds-core-jndi:jar:1.5.5:test
       |  |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
       \- org.apache.directory.shared:shared-ldap:jar:0.9.15:test
          +- org.apache.directory.shared:shared-asn1:jar:0.9.15:test
          |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
          +- org.apache.directory.shared:shared-ldap-constants:jar:0.9.15:test
          |  \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)
          \- (org.slf4j:slf4j-api:jar:1.5.6:test - omitted for conflict with 1.7.21)

1.7.21
  1. com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2
    \- org.slf4j:slf4j-simple:jar:1.7.21:compile
       \- org.slf4j:slf4j-api:jar:1.7.21:compile

  2. com.btmatthews.maven.plugins:ldap-maven-plugin:maven-plugin:1.3.2
    +- org.slf4j:log4j-over-slf4j:jar:1.7.21:runtime
    |  \- org.slf4j:slf4j-api:jar:1.7.21:runtime
    \- com.btmatthews.maven.plugins.ldap:server-apacheds:jar:1.3.2:test
       \- org.slf4j:slf4j-simple:jar:1.7.21:test
          \- (org.slf4j:slf4j-api:jar:1.7.21:test - omitted for duplicate)